InDesign Chapter 8: Importing and Exporting

How do I import and export content to and from Adobe InDesign?

 Instructions

Section 8.1: Importing Content from MS Word

  1. In the Main Menu, click the File tab, then click Place.

    File Tab in Adobe InDesign
  2. Find the document you want to import, check the Show Import Options button and click open.

  3. In InDesign, click and drag to create a box. Your word document text will appear in the box.

    Adobe InDesign Page with the Fredonia ITS Hierarchy.

Remember, you can only import text from Word from InDesign. If you had any images, you will most likely have to recreate them in InDesign.

4. To match the Word Styles to InDesign’s styles, go to the File Tab, then click Place.

File tab in Adobe InDesign

5. Under the Format option, click Customize Style Import Option.

6. Click the blue Style Mapping button. This will open up a Style Mapping Box. Sometimes the styles will match as they do in the example. If they do not match, each style box has a dropdown menu containing lots of styles to choose from. Look through them and select the styles that do match.

7. Click OK in the Style Mapping Box and the Import Options Menu. Then drag and drop your content into InDesign. It should be formatted like it was in MS Word.

Section 8.2: Exporting InDesign Projects to a PDF

  1. Click the File Tab, then click Export.

  2. If you are trying to make your document for a website, save it as ADOBE PDF (Interactive). If you are trying to make the document available for printing, save it as ADOBE PDF (Print).

    1. For saving as an ADOBE PDF (Interactive), check the options for “Create Tagged PDF” and “Use Structure for Tab Order”.

    2. For saving as ADOBE PDF (Print), you have a different set of options. You need to change the compatibility drop menu to Acrobat 6 or higher. Then go to the Options section, and check Create Tagged PDF. Finally go to the Include section and check Bookmarks and Hyperlinks.

       

  3. Now we have to finish the job in Acrobat. Go to the File Tab and click Properties.

  4. In the Document Properties Tab, click the Description Tab and name your project in the Title Field.

  1. Now you want to set the Initial View of the document. In the Document Properties box, click the Initial View tab. In the Windows Options Section, click the Show dropdown menu and choose Document Title.

     

     

  2. Specify the language. Go to the Advanced Tab of the Document Properties box. Under Reading Options, click the Language drop-down language and choose English.

     

  3. Check the Tag Structure and the Reading Order.

  4. Set your documents Tab Order. Click the Page Thumbnails Pane, then click the Options drop-down menu. Click Page Properties. In Tab Order, check the box for “Use Document Structure.” Click OK and your done!

Section 8.3: Exporting InDesign Projects to EPUB

  1. Go to the Main Menu, and click the File Tab, and select Export.

  2. In the Export Box, Select EPUB (Reflowable) in the Save As Type dropdown menu.

  3. In the EPUB Reflowable Layout Export Options, be sure that the Version Setting is at EPUB 3.0.

  4. Next go to the Object Section. In CSS, choose between having the size fixed or relative to text flow. Go with the one that looks better.

  5. Go to the Metadata and give your document a title. Click OK.

Section 8.4: Exporting InDesign Projects to HTML

InDesign is not the optimal tool for creating web pages; however, it is possible to convert InDesign files to HTML format.

To export as HTML, navigate to File > Export and select "HTML" from the "Format" drop-down menu.

InDesign keeps most, but not all, of the accessibility markup during HTML export, InDesign maintains the document title, heading structure, and alt text for images, effectively preserving important accessibility elements.

Regrettably, InDesign fails to designate header cells in data tables correctly as <th> tags. Instead, it labels them as <td> tags, causing screen readers to interpret them as data cells instead of header cells. If you export an InDesign table to HTML, you will need to manually modify the HTML source code to convert the header cells to <th> tags. While InDesign does enclose the header rows within <thead> tags, this alone is insufficient for marking the header cells appropriately.