MS Excel Chapter 12: Saving and Exporting Files

How do I save and export my content in Microsoft Excel software in an accessible way.

 Instructions

Section 12.1: Saving Excel Files

  1. Do a spell check. (Not the D&D kind)

    Review Tab in Microsoft Excel.
    ABC Spelling Button in Microsoft Excel with a green checkmark.
  2. Preview the print layout by clicking File > Print. View how the sheets will appear when printed.

    File Button in Excel.
  3. Set the print area by highlighting the range of cells you want printed. In the Page Layout tab, select Print Area, then Set Print Area.

     

  4. Fill out the metadata/properties.

  5. Give the file a clear name with no special characters.

Section 12.2: Exporting Excel Files as a PDF

  1. Save your file.

  2. Click File, Save As, and choose a location for saving.

  3. In the “Save as type” drop-down menu, select PDF. Below this, you will have to fill out the fields for Authors, Tags, Title, and Subject.

  4. Click the Options button. Specify the Page Range, and Publish What sections as needed. Under Include non-printing information, make sure that the options for “Document properties” and “Document structure tags for accessibility” are both checked.

  5. Hit OK.

Most of the document should be correctly tagged, including table structure and link tagging. However, you will likely need to go in and do some manual touch-ups. Automatic tagging is not perfect and (for now, at least) always requires manual checking. For instance, even if you add alt text in the specific alt text area of an image within Excel, this will not transfer over to your PDF and you’ll need to manually tag it.

Section 12.3: Exporting an Excel File as HTML

  1. Save your file.

  2. Click File, Save As, and choose a location for saving.

  3. In the “Save As Type” dropdown menu, select Web Page or Single File Web Page.

Section 12.4: Exporting Excel Files as a CSV File

Overview: A CSV file is a comma separated values file that stores data in a basic table structured format (values separated by commas, hence the name). It does not store any type of formatting and can only contain a single sheet. CSV files are compatible across all spreadsheet programs and can also be created and opened with any text editor.

  1. To save as a CSV file, click File, Save As.

  2. Choose the location for saving.

  3. From the drop-down menu for "Save as type," select CSV.